Jan 012020
 

Next up in the box of brokenness is a Pacland.

Visual inspection revealed the amp had blown up

I also saw the usual corrosion on the legs of some of the customs

and the socket didn’t look too great either

As you would expect there were some pins missing from the chip when I removed it

I soldered legs on best I could and opted to fire the board up.

This is a good start and using the error code list compiled by my good friend cmonkey I knew that this was a RAM fault.
Checking RAM 9N I found several address lines were dead

Using the schematics I could see those address lines came from a 74LS32 @ 10J

I confirmed the outputs were bad and replaced the chip.
Now I get this when booting

Game is booting but some scroll issues and some jailbars too.
I could affect the scroll issues by pressing on that custom chip I resoldered at the start. I removed it again and attempted to further clean the legs but I just made it all worse. In the end I opted to solder it into a socket.
It looks crappy but it got the job done

Scroll issues fixed I now turned to those jailbars.
This ended up being an easy fix. I removed the ROM at 6T and checked it in my programmer. Bit 5 was stuck high so I replaced the ROM which fixed the jailbars.

Last thing to deal with was the sound. Obviously I wasn’t going to get far without an amp and I don’t have any spares. Lucky for me, my friend Smarty sent me a replacement gratis which fixed the sound and completed the repair.

Thanks very much to Smarty for the amp.

 Posted by at 10:08 pm

  2 Responses to “Pacland repair log #3”

  1. Nice fix buddy. It’s good to know that the boot time error code list that I knocked up many years ago still comes in handy occasionally!